Volkswagen Mark IV Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
Hello my friends If you guys remember, I posted a post regarding MPG someone told me here from the forum that clean your MAF today I went to halfords & bought the spray cleaner to clean the MAF.

When I opened the bonnet I saw there is a plug missing where the MAF stystem is , If you understand what I mean I looked around if there is any wire hanging around but nothing seems like it the wire is missing which connects to the MAF can anyone tell me where the othere end goes from MAF to ?

Please help me quick.

Is this the reason I am getting very poor MPG , Help me please, please, please.......

I has a good look around the engine to find if any sort of plug wire is hanging down but nothing there, Seems to me it came off & fell down from the car.

Any Clues????

Posted Image


Posted Image


Posted Image


Posted Image


Posted Image


Posted Image
 

·
Registered
Joined
·
4,190 Posts
definitly needs a plug on it........

that plug would tell your cars ECU what air is being taken in etc....

and 100% the cause of your problems,,,,,i think.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #7 ·
So this means it is missing can someone tell me please where the other end goes.

One end goes on the mAF system wher goes the other end can someone show through pics please if possible.

How much is it if I have to buy it from VW or euro car parts please help......

Is theis the reason you reckon guys I am getting very Bad MPG????????????????????????????????????????????
 

·
Registered
Joined
·
1,375 Posts
well look at it this way the MAF tells the ECU that the air going into your engine is 'x' temp and it pumps in fuel acordingly

Now if that it un-pluged it will be reading the lowest reading (i.e. -10 degrees c ) which means your car will be pumping in too much fuel for the required temp thus over fueing and very poor MPG

where did you buy the car and was the plug on it before?
 

·
Registered
Joined
·
5,827 Posts
well look at it this way the MAF tells the ECU that the air going into your engine is 'x' temp and it pumps in fuel acordingly

Now if that it un-pluged it will be reading the lowest reading (i.e. -10 degrees c ) which means your car will be pumping in too much fuel for the required temp thus over fueing and very poor MPG

where did you buy the car and was the plug on it before?
I thought the maf told the ecu how much, not what temperature ?
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #13 ·
Can I fbuy it from the dealer or somewhere else & How much is it , What is it called exactly & can someone tell me where the other end goes if someone can show me through their pics will be great .

I mean their engine bay so Ill get the Idea wher to plug the wire.

Many Thanks
 

·
Registered
Joined
·
824 Posts
Not sure where the other end goes,but from the dealers they cost around ?300ish. Can you not go back to where you bought the car and question them? If not,have you removed the engine cover or looked deep in the engine bay to see if it has been disconnected and hidden else where. If it has,and it's faulty you can return it to VW and pay ?70 and get a new one instead of the ?300. hth
 

·
Registered
Joined
·
722 Posts
I am pretty sure that if search around the area, you will find the plug and the loom, the maf may very well be ok if you clean it. Have a good lokk, it may be tucked up behind the pipework.

SB
 

·
Registered
Joined
·
99 Posts
I am sure there is a black box that attaches to the triangular bracket at the back of the engine bay as you can see in the above picture. The wire from the MAF goes into there I think. Not sure where it goes after that.

I have added a pic below from another post (Thanks 180Turbo - Hope you don't mind)

You can see the box I am talking about. This is on a 1.8t. Not sure if it is the same for a non-turbo engine??

http://www.pyeomans.f2s.com/pics/right.jpg
 

·
Registered
Joined
·
626 Posts
Just looked at the wiring diagram for a agn and most of the wires are going  to the ecu, So the wires will be coming of the main loom from the ecu at some point.
 

·
Registered
Joined
·
626 Posts
I am sure there is a black box that attaches to the triangular bracket at the back of the engine bay as you can see in the above picture. The wire from the MAF goes into there I think. Not sure where it goes after that.

I have added a pic below from another post (Thanks 180Turbo - Hope you don't mind)

You can see the box I am talking about. This is on a 1.8t. Not sure if it is the same for a non-turbo engine??

http://www.pyeomans.f2s.com/pics/right.jpg
No thats the Barometric pressure sensor, what ever that is[:cool:] But dont come on non turbo.
 

·
Registered
Joined
·
194 Posts
I am sure there is a black box that attaches to the triangular bracket at the back of the engine bay as you can see in the above picture. The wire from the MAF goes into there I think. Not sure where it goes after that.

I have added a pic below from another post (Thanks 180Turbo - Hope you don't mind)

You can see the box I am talking about. This is on a 1.8t. Not sure if it is the same for a non-turbo engine??

http://www.pyeomans.f2s.com/pics/right.jpg
No thats the Barometric pressure sensor, what ever that is[:cool:] But dont come on non turbo.
measures air pressure.....as in barometer, that thing that tells you when it's going to rain.......

sorry, but i laughed when i saw the first pic......it looks lost without it's plug...[:'(]

it'll be part of the engine harness that's routed around the whole engine bay i'd have thought.......it must be somewhere.

[;)]
 
1 - 20 of 25 Posts
Top