Volkswagen Mark IV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi guys, noobie here.

I would like to install an aftermarket head unit to replace the OEM Delta6 radio, which appears to be coded/aligned to the car's security system. When I replaced it with the aftermarket head unit, the cars electrics were immediately killed when I turned the ignition. When I reinstall the OEM radio, the car operates as normal.

How does one install an aftermarket head unit in this situation? If it helps any, I do have the radio code from the owner manuals.

FYI I've noted on the OEM radio harness pins 9 (CAN+), 10 (CAN-) & 16 (+SAFE) are wired (used) - on the aftermarket harness, these pins are empty (not used).

Any help gratefully appreciated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
A radio cannot turn off the electrics. Something else is amiss.
Thanks for your reply. Anything I should check as a start?

We are week 4 into lockdown with all garages/radio installers shut, so I'm just making use of my spare time... I do have a multimeter if it helps any.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
An immobilised MK4 will start, run for two seconds and then turn off. If it's not doing that, it's not immo.

Does it do it with no radio connected at all?
Yep, that's exactly what happened - lights on dash showed up momentarily then all the electrics went. I got nothing when turning the key again.

I will check tomorrow whether it starts without the OEM radio connected. Should I disconnect battery first? Or do you want to see if the immo kicks in when the radio is removed?
 

·
VR6 GT35 4mo
Joined
·
11,321 Posts
No, that's not what I meant. I mean that it will start, run and then shut down. You still have power. It just signals the ECU to stop running, but everything still has power. Cycling the key will repeat - start/run/shutdown.

It's NOT the immo.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Hmm, ok. Actually I didn't even get to turnover the engine at all because all the electrics went. So you're saying the immo is NOT doing this but something else?
 
1 - 8 of 8 Posts
Top