Volkswagen Mark IV Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter · #1 ·
yeah went to VW in Coventry .. they didnt know wat an N75 was .. IDIOTS MAN !! was well pissed off ..what do the dealers call them things ???? ..

i explained the thing so well to parts department and even showed them the part in the engine bay.. and they got in the wrong part, was so angry.. so what do i say to them ??

and finally .. what does this N75 thing do guys .. summin to do with boost pressure ??? cos when i run my car in standard mode with the sps2 ..when my foots down in 2nd.or 3rd .... after abt 3k revs .. the car sorta surges and boost seems to go down .. i can feel it .. car sorta holds back ... could this be to do with air flow meter cos ive changed it twice now .. or could it be to do with this N75 thingy ??? im soo confused at the mo ..

and this could be the reason y i only got 185 bhp in essex ..cos my boost aint fully comin on ..
 

·
Registered
Joined
·
2,623 Posts
Hi Vinny,

Have you ahd the fault codes read yet to see if there is an obvious problem, have you taken it back to the original tuner yet, have you tried it with optimax or BP Ultimate?

As these are avenues to try before swapping out the N75 for the J version as most tuning software is written to work with the standard valve.
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #4 ·
oh yeah // the N75 im gonna be changin is for the original one (i think).. isnt this the one the dealers supply anyway when u order a replacement?
 

·
Registered
Joined
·
2,623 Posts
they refer to it as a solenoid, you obviously don't have a very helpful parts department mine spent a good 5 minutes looking in etka before going outside seeing where it was in the engine bay then going back and finding it.
 

·
Registered
Joined
·
87 Posts
Unfortunatly the parts software (etka) rarely has the technical coding from the workshop manual (elsa) in fact sometimes even the descriptions are different such as elsa describe air mass meter and etka describe air volume meter. So don't be too harsh on the parts guys.
 

·
Registered
Joined
·
2,164 Posts
Vinny,

Have you tried cleaning the pins on the plug for your maf and the
ignition module that sits on the side of your air filter box .Also give
your throttle body a clean too.

If you havnt tried these already give them a try before throwing any more money at the car .

Its worth a try.

Mo
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #9 ·
hey mo cheers !!! the thing is though .. my MAF is brand new ... AND the clever gits have now put security screws on the MAF housing which means u cant take that thing out of its housing. it comes as ONE part now .. so i cant even clean that ... maybe a faulty revo map possibly.. cos even in std mode i can feel the car surge jus after 3k on the revs when floorign it in 2nd .(u car hear that weasing sound suddenly drop in pitch) then go ok again ??? .. its ok though .. stealth r gonna book me in .. the guy said hes got a spare N75 so he gonna try that too.. the prob in std mode could be whats causing the lack of power in mapped mode ..

aint gotta clue how to clean throttle bodies etc. .. im not that mechanically minded with cars unfortunately
Huh? [:^)]
 

·
Registered
Joined
·
2,164 Posts
Vinny,

You dont have to take the maf apart.On the side of it is a black plug
with 4 or 5 pins in it.Clean the pins.They sometimes break contact if
dirty and can give the illusion of a faulty maf.Dealer will just swap
out the maf without even trying to clean the pins.
 

·
Registered
Joined
·
1,375 Posts
This is the exact psame problem i have on my car since getting it re-maped

I have checked/replaced most parts and have came to the conclusion its my N75 valve

I too also phoned two dealers in my area for a price quote and both didnt have a clue what an N75 valve was as they had it down as a Pressure regulator

What model of engine is this for ?

I was quoted ?67 + VAT for mine from VW nd ?59 + VAT from one of the VW specialist parts places

Oh and my dawes device seemed to fix the problem for me
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #12 ·
wat do i use to clean the pins with .. do i jus take that plug off and clean the pins there ??? and also .. craig .. so wat did you do in the end to cure the problem ?? cheers ...
 

·
Registered
Joined
·
2,164 Posts
Yep, hit the nail on the head, use a pen Knife or small flat head screwdriver to scrape the pins
clean.Also on the side of the air filter box undo the plugs on the
ignition amp module (if your car has one) and clean them in the same
way.

The reason to clean the pins is that if they lose contact they will
give symptoms of a faulty maf. The dealers wont clean the pins on the
plug, they will just swap out the maf, and it may to appear to solve
the problem until the contact is lost again and weyhey it looks like
the new maf is faulty too.

Let us know if it makes any difference.
 

·
Registered
Joined
·
1,375 Posts
I fitted a dawes device boost conrtoler and it seems to have stopped most of it but i did get a slight hesitation this morning but nt sure if it was maybe turbo lag
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #15 ·
no luck guys !! ... changed the MAF today .. old one was still under warranty so got a new one in exchange .. also changed the N75 !!! and guess wat !!!!!! NOTHING !!!!!!!!! no change at all ... in stock mode ... foot down fully .. jus before 3k .. u feel loads of pressure building up .. then afer 3k .. it seems to die out .. almost like a limp mode or summin .. so no change at all .. not impressed ... oh well .. dunno wat to do now ... gonna get stealth to haev a look ... might eb a leak in boost pipe or summin .. i dont know now :( :( .. ill let u know wat happens
 

·
Registered
Joined
·
2,164 Posts
Vinny has a 1.8T so no veins on his turbo.

Vinny,

Good idea to get it checked out now with some diagnostics.

1 last thing.Have you checked all of your vacuum hoses(the one for the
dump valve and the other end of it up at the front of the engine and
also the one on the fuel pressure regulator ?

Hopefully stealth will find out what your problem is.
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #19 ·
its ok tom ... got the replacement N75 ... it said F at the end of the part number. .. changed it .. F*K ALL difference. still got the pull back hesitation after 3k. u hear the boost come in at abt 2.5k with ya foot floored, then as it passes 3k .. u feel it die away then come back slowly. u can hear the change in that whistling tone. i dunno .. stealth will look at it when i take it down .. will let u lot know what happens. thanks for the help
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #20 ·
i replaced mine with teh standard F valve ... wats the J one do ??? my car is REVOd too ... with Forge DV
 
1 - 20 of 20 Posts
Top