Volkswagen Mark IV Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
258 Posts
Discussion Starter · #1 ·
Body:

Just seen a post in the DIY section. Why do people use the Merc MAF instead of the VW standard?

Would it fit a 2000 Bora TDI, if so does anyone have the partnumber and cost?

Cheers
 

·
Registered
Joined
·
1,932 Posts
basically cos the VW one is rubbish and the MERC one is a cheaper, more reliable replacement! Mine cost ?50 18months ago, but they are around ?60 now! VW will do u an exchange one for around ?75, as before they just offered a new one at ?200+! u only need to change the MAF if your getting severe power drop off after 3k rpm!

HTH

Paul
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #3 ·
u only need to change the MAF if your getting severe power drop off after 3k rpm! HTH Paul
I do get that actually!! [:O] Didn't realise it could be something as simple as that... May have to give it a go! Cheers!
 

·
Registered
Joined
·
1,932 Posts
i see you have a PD engine. As far as i know they dont work so well with them, much better in the non-PD 110 like mine.

cant remember the part number, sure its in a post somewhere on here though
 

·
Registered
Joined
·
4,628 Posts
u only need to change the MAF if your getting severe power drop off after 3k rpm! HTH Paul
Bummer why didn't I find this site earlier - that explains a hell of a lot why I thought my TDI115 was going down the pan, a simple MAF job... [:(]
 

·
Registered
Joined
·
1,932 Posts
u only need to change the MAF if your getting severe power drop off after 3k rpm! HTH Paul
Bummer why didn't I find this site earlier - that explains a hell of a lot why I thought my TDI115 was going down the pan, a simple MAF job... [:(]
lol, i thought it was normal til i came across this site! changed the maf and never looked back!

MAF is the usual cause to this problem anyway!
 

·
Registered
Joined
·
4,628 Posts
Exactly [:'(]

Oh well doubt the stealer's will fix it, so I hope it's next owner turns up here or somewhere similar!!! [:)]
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #9 ·
Just unplugged my MAF and went up the road... WHAT A DIFFERENCE!!! my cars been like it since I first got it six months ago.... I thought it was just slow!!! [:O]

How long could I keep it unplugged I want a quick spin up the motorway!
 

·
Registered
Joined
·
2,634 Posts
I got an exchange MAF for mine for ?65 fitted it myself - as has been mentioned the Merc MAF doesn't work well with the PD engines.
 

·
Registered
Joined
·
27 Posts
I didnt realise that you shoudnt use a mer maf on a pd engine? Ive been using one for a couple of months and it has felt fine, I do not really have much to compare it to as the maf I had previously was knackered.

Is it just a performance thing or am I actually doing damage to the engine?
 

·
Registered
Joined
·
2,379 Posts
Lads instead of buying a new maf clean them, as i did that to my mums
maf and the car flew after that. Cleaning them will only cost ?5 and I
cleaned 2 mafs with it and still had loads of the electric cleaner left.
 

·
Registered
Joined
·
2,634 Posts
I didnt realise that you shoudnt use a mer maf on a pd engine? Ive been using one for a couple of months and it has felt fine, I do not really have much to compare it to as the maf I had previously was knackered.

Is it just a performance thing or am I actually doing damage to the engine?
I don't think it damages the engine, it's just that some users found their car didn't respond well to the Merc unit.

Cleaning doesn't always work - if it's knackered then cleaning won't make any difference. I've still got the can of cleaning spray....[;)]
 

·
Registered
Joined
·
293 Posts
i bought myself a MAF in german swedish french for ?37 + VAT this morning, as i was having severe acceleration problems above 2.5k rpm. fitted it myself (really need 3 hands), then went for a spin. without speaking too soon, it seems to have been the problem. i was hitting 3.5k with ease in 2nd upon my return home, so well happy now.
 

·
Registered
Joined
·
31 Posts
Just to clear this MAF thing up a bit. A lot of people are blaming VW for this problem, when in actual fact its a Bosch problem, as it's Bosch who make them. VW have switched to Hitachi for the MAF meter in the MkV GTI, which hopefully will be more reliable.
 

·
Registered
Joined
·
258 Posts
Discussion Starter · #17 ·
I just this taken my one apart given it a clean and put back to together and she goes like a little rocket (Compared to before). The two little fork type sensors were alittle black looking so I don't know if this was part of the problem?

But anyway, I'm well chuffed now!
 

·
Registered
Joined
·
2,379 Posts
I just this taken my one apart given it a clean
and put back to together and she goes like a little rocket (Compared to
before). The two little fork type sensors were alittle black looking so
I don't know if this was part of the problem?

But anyway, I'm well chuffed now!
glad to hear mate, see what a little d.i.y can do. [y]
 

·
Registered
Joined
·
1,932 Posts
I just this taken my one apart given it a clean and put back to together and she goes like a little rocket (Compared to before). The two little fork type sensors were alittle black looking so I don't know if this was part of the problem?

But anyway, I'm well chuffed now!
cool, glad it worked! Aren't forums a great thing [Y]
 

·
Registered
Joined
·
293 Posts
lol, if id read this thread before today, i would have attempted to clean mine + try that first, before buying a new one! in saying that, when i took the old one off, i was amazed to see how simple a thing it was, and how on earth any part of it could cause the car to greatly reduce acceleration.
 
1 - 20 of 21 Posts
Top