Volkswagen Mark IV Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
883 Posts
Hi guys.
Just a basic 'How To'. I've had my Golf nearly 2 months, and in that time all i've done is put right broken things right, and this is one of them. Basically, my trip computer should have shown this when the key was in the ignition and the boot opened:
IMG_3733.jpg

But it didn't. So after a bit of research, I found out that a dodgy wiper motor had been leaking into the latch on the bootlid frying the microswitch, which in turn was stopping the bootlight come on and the non display of the above message...
So, I called VW and found out what the part number and price was to repair this. You will however, have to disconnect/remove/fix your rear wiper motor before you do this reapir otherwise you'll end up needing to do this again. I repaired mine, but some may want to remove etc.
So, for this 'How To', you will need:

  • The boot latch, part no: 1J6 827 505 CB 41. Price (exc. VAT) is £24.46.
  • A Phillips screw driver, an mate Spline bit (like a Torx, but more edges), possibly a smaller flat bladed screwdriver and maybe some WD40.
  • Possibly this little plug, part no: 1J0 973 115. Price (exc. VAT) is £1.24. However, you can buy this part with about 1" of wiring coming out of it (not sure on part no) so you can splice the wires to the original loom, which is about £2-I would recommend that as it can be very fiddly.

1) Open the bootlid, and inside the grab handles are a single phillips screw, one each side. Remove.
IMG_3721.jpg

2) Prise the trim off. This can be quite tricky as the tabs holding it in are quite strong, plus remember, plastic can be very SHARP, so watch your fingers.
IMG_3722.jpg

3) Once the panel is removed, you will see the mechanism inside:
IMG_3737.jpg

Underneath the mechanism are the two pieces that need to be disconnected. One is the small metal arm that pulls the latch open/shut (right side), the other is the electrical connector (left side).
4) The metal arm needs to be removed before you undo any bolts. It's not too tricky. Just hook your finger around it and pull it out of the small white plastic pin that it's going through. Be careful not to bend it as it may require a little bit of force. Don't worry if the white plastic tab breaks as there is a new one on the new latch.
IMG_3729.jpg

5) Now you can unclip the wiring loom from the tabs holding the wire in place:
IMG_3738.jpg

6) Now use your mate bit to remove the latch from the bootlid:
IMG_3723.jpg
IMG_3734.jpg

7) Now that the two bolts are out, you can pull the latch out and pull some of the wiring through. You will now be able to see the small connector going into the latch.
IMG_3724.jpg

8) This is where it can get tricky. The connector has a small tab on which needs to be levered to pull it out, however, depending on how long the switch has been soaking in screenwash will depend how easy it is/isn't to get out-the tab may be very brittle and could snap off (like mine!). Don't be tempted to just pull the wiring. This could yank all the wires out of the connector block, or even snap them. If you can't get it out, just give it a generous helping of WD40 and some wiggling and it should eventually come out (not like mine...[:cool:] - see NB at foot of this page).
9) Once removed, you can see the difference:
IMG_3728.jpg

10) Before reassembly, check that it has worked! Hold the latch and connect the loom: the boot light should come on. If it doesn't, check the bulb is in or not blown. If I remember correctly it should light up without the key being in the ignition. Then, get a friend to hold the latch, ensuring the locking mechanism is flicked open, and jump in the drivers seat. Shut your door and turn the ignition on without starting the car. You should hear a small 'tone' and see this message on the on-board display:
IMG_3733.jpg

If it does, then you're ready to reassemble. If you don't, check that all the connections are clean. If it's all green (like mine was), then WD40 and a rag will get most of it off. It worked for me so should for you too. If it still doesn't work, then you may have a more deep seated issue that I can't help you with!
11) Clean up your connector, and start to reassemble in the reverse order, which goes like this:
Connect wire to latch > Bolt latch back to bootlid > Press metal arm back up through new white plastic hole (ensuring it goes through fully using the locating groove) > Put loom back into metal tabs > Replace boot trim > Replace Phillips screws in boot grabs.
And there you have it. I'm not sure if it's the same for cars without the on-board computer, but this is for cars with. I would imagine it's the same just minus the message, but you'd need to find that out first.
One of those satisfying jobs: it should work, so make it work! No point modifying a car if all the little bits aren't done first.
Hopefully it'll help some people. If i've left anything out let me know!
Dan
NB: I should note that the connector on mine was welded in with limescale, the tab on the block did snap, and so did the wire (no fault of my own, it was just so corroded and very very fragile). I have managed to sort a temporary wiring solution for the time being, but next time i'm at VW, i'll be finding out if the connector (see pic) is available to buy. I'll update this info as/when I have it.
IMG_3730.jpg

Can be purchased with about 1" of wire, which I would recommend (about £1 more).
IMG_3775.jpg
 

·
Registered
Joined
·
262 Posts
I've got this problem and have done since owning the car for nearly a year now. I've always been too hesitant thinking that VW will charge me 100 pounds to get the boot light working or whatever, I'll definitely be doing this when we get some nicer weather [Y]
 

·
Registered
Joined
·
147 Posts
Nice write up dude. I contacted VW, & they deny all knowledge of being able to source the plug part with the additional 1" of wiring. They have both the boot mechanism & the plug on their systems, but no sign of the plug with additional wiring (unless you pay £70 for the plug with full wiring harness).

My boot light has never worked, & I've never seen the 'Luggage comp. Open' message either, so sounds like I've the exact same issue as you had.

Should my 2000 GT TDi 115 have the 'Luggage comp. Open' message & icon?
 

·
Registered
Joined
·
883 Posts
Discussion Starter · #5 ·
Nice write up dude. I contacted VW, & they deny all knowledge of being able to source the plug part with the additional 1" of wiring. They have both the boot mechanism & the plug on their systems, but no sign of the plug with additional wiring (unless you pay £70 for the plug with full wiring harness).

My boot light has never worked, & I've never seen the 'Luggage comp. Open' message either, so sounds like I've the exact same issue as you had.

Should my 2000 GT TDi 115 have the 'Luggage comp. Open' message & icon?
Strange about the plug without the wiring, the parts dept at my VW offered me the plug with and without. Perhaps it's NLA?

With regards to the Luggage Open message, I couldn't say for def. as yours is a different model to mine, but your symptoms, as you say, are identical. The easiest way to check would be to remove the boot trim as in steps 1 & 2. If your wiper motor has been leaking, then there's a good chance that the spongy material on the rear of the trim is going to be damp/mouldy/rusty-water-looking (good description eh?]. You can then have a look at the little plug that goes into the microswitch, and if thats all corroded, then thats the problem. As a check, you can close the boot, jump in the front and squirt the window. Then open the boot again and see if there is any water dripping inside...

Piece of cake to do, although if you do need the little plug, it's a fiddly little sod! But do bear in mind, if your wiper motor is leaking, then replacing the latch will be a waste of time as it will eventually get ruined again. You'll need to buy a new wiper motor or I think VW do a repair kit for it, but you'd have to check with VW.
 

·
Registered
Joined
·
147 Posts
Well I managed to remove the boot mechanism with ease thanks to your simple guide. In all honesty I didn't follow the instructions exactly in order, but the result was the same nonetheless.

I hadn't purchased a replacement switch, as I just wanted to check to see if:

A: The wiper had leaked

B: Whether or not I could clean up the existing mechanism/contacts without having to purchasing new parts.

I can report that there has been a leak at some point, but it doesn't appear to be recent, nor does it appear to be leaking upon testing. I came to the conclusion that the leak may have possible originated from around the boot handle judging by the deposits left behind [:cool:]

Cleaning up the switch & plug with rust cleaning spray didn't fix the fault, so looks like I'll be sourcing replacement parts this week.

I'll report back once I've fitted the replacement parts.
 

·
Registered
Joined
·
147 Posts
Well I managed to complete the replacement of the parts above with the aid of this guide, so thanks very much to dantheman1981 for providing it.

I now have a working boot light & the central locking/alarm also works as it should when the boot is open :)

However, the luggage compartment warning lights don't show on my 2000 GT TDi, so I'm now trying to figure out whether or not it actually has this feature...
 

·
Registered
Joined
·
2,913 Posts
Dont quote me on this but i think its only late 2001 canbus cars that have the Luggage com Open feature i never seen it on my 1999 car which has immo3 boro sport clocks fitted.
 

·
Registered
Joined
·
251 Posts
excellent write up [:D]

i think i will be trying this along with the washer pipe replacement as my boot sems to not want to open as of this morning
 

·
Registered
Joined
·
1 Posts
I have the same problem at the moment. Used your guide to disassemble. Very helpfull thanks. Quick question, the connector block on the boot locking mechanism was it a 3 pin connector? on mine it looks like 2 of the pins have snapped and are inside the other connector if u know what i mean.
 

·
Registered
Joined
·
1,475 Posts
Subscribed! You've reminded me actually that my boot is open and doesn't lock lol. Really must get this sorted. Where can you get a plastic cover to replace the wiper motor should I choose to delete it?

Thanks for the guide [:)]
 

·
Registered
Joined
·
186 Posts
my Golf mk4 Anniversary's boot light won't come on. I did have a leak in the 'C' pillar where the screen wash pipe had 'popped' off. I fixes that and dried it out but no light in the boot. I checked the bulb and replaced it but still no luck.

There doesn't appear to have been a leak on the lock, but I can't say for sure. Could this be a fix for me? I don't get any warnings on the dash though!

Cheers

Dan
 

·
Registered
Joined
·
585 Posts
i have a v reg golf and had exactly the same problem as you. boot light wouldnt come on when the boot is open and i thought maybe its just the bulb so i changed that and it wasnt so i bit the bullet and brought a new locking mechanism and the small plug that plugs into it. plugged the plug into the new boot switch and it worked fine so i figured i needed to change the boot lock mechanism and as i had a new plug cut the old wire back about 12mm so it has a fresh connection and put the plug on and all works perfect now.
 

·
Registered
Joined
·
186 Posts
i have a v reg golf and had exactly the same problem as you. boot light wouldnt come on when the boot is open and i thought maybe its just the bulb so i changed that and it wasnt so i bit the bullet and brought a new locking mechanism and the small plug that plugs into it. plugged the plug into the new boot switch and it worked fine so i figured i needed to change the boot lock mechanism and as i had a new plug cut the old wire back about 12mm so it has a fresh connection and put the plug on and all works perfect now.
Spot on, got a new catch from vw and all sorted !! thank you!
 

·
Registered
Joined
·
38 Posts
Brilliant guide, my boot light hasn't worked in 2 years and only after reading this post I realised that the light on the trip computer has never come on either.

Going to ring around GSF, Euro Car parts, etc to see if I can get one. I'm picking my car up from Cardiff VW today as it's in for a minor service so I'll ask in there too.
 

·
Registered
Joined
·
1 Posts
Thats an excellent guide - thankyou.

However, ive just replaced the boot catch on my 2002 golf and i still get the boot open icon and an annoying noise when i drive round.

Should i replace the plug as well as the catch?

Ive also got an issue (for about 3 months prior to my boot going wrong) where it doesnt recognise my driver side door is being opened. Im just in the middle of stripping out the door to get to the module at the moment. WOuld that be related?

Thanks for the guide though

W
 

·
Registered
Joined
·
26 Posts
Great! i did this before, to replace the lock barrel, thats when i noticed the same issue, corroding on the pins, which was the reason my boot light wasnt working.

i have often thought about replacing it. but i did not have and did not know the name of the M8 bit. many thanks for that.
 
1 - 20 of 39 Posts
Top