Volkswagen Mark IV Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
51 Posts
Just given up on my 2003 Passat Tdi

All went well with the stalk by following Foxy?s guide.

Small problem at the fuse box. I think it should be fuse 6 and not 5 on the Passat.

Big Problem when I got to connecting up the pins to the black plug under the bulkhead. The pins are already in use.

I will need to get a wiring diagram for the cruse control for this model to take this one forward.

This might take a bit of time.

Any idea where I might get my hands on a wiring diagram?
 

·
Registered
Joined
·
808 Posts
I fitted one not that long ago, I bought a new stalk with the cruise control switch and the small multiplug to go with it, and I made the small wiring loom myself, once fitted all you need to do is activate the ecu for it and hey presto your in, I might even re-post the info if I get round to it
 

·
Registered
Joined
·
692 Posts
Quote: posted by weeloon on 22/11/2004 00:31:04

I fitted one not that long ago, I bought a new stalk with the cruise control switch and the small multiplug to go with it, and I made the small wiring loom myself, once fitted all you need to do is activate the ecu for it and hey presto your in, I might even re-post the info if I get round to it

If you could repost that mate that would be a great help to dava.

Cheers.
 

·
Registered
Joined
·
51 Posts
[:D]Great news!!!!!

I have managed to get hold of the wiring diagram for the Passat.

I will do some work on this at the weekend and follow this one up.

Any help before then would be helpful.

Thanks
 

·
Registered
Joined
·
51 Posts
The 2003 Passat TDi has now got Cruse Control Fitted and working.[:D]
Here is the additional information to Foxy?s instructions.
Important reminder: when looking at wires the first colour is the main colour and the second colour is the trace colour. E.g. Red/Yellow the wire is Red with a Yellow Trace.

This bit is for info only and probably won?t ever be needed again.
The ECU on the Passat TDi uses pins 14, 44, 45, 46 for the Cruse Control.

The work stars here:
ECU Pin----ECU Cable Colour----CC Loom Colour---Loom Marking----White Multi plug
14-----------------black/white--------black/yellow----------KA3--------------11
44-----------------red/yellow---------orange----------------KA2--------------9
45-----------------blue----------------blue-------------------KA1--------------8
46-----------------red/grey-----------white------------------KA9--------------7

Fuse 6 (5amp)-------------------black/blue

All the pins are located in a White multi plug located below the ECU in the Bulkhead in front of the steering wheel (under the plascic cover under the bonnet beside the wiper mechanism.
Posted Image


Stop, there is a problem with the pins on the loom, they are the wrong size.
The pins required are the same size as the ones you will find in the D plugs fitted to your computer monitor, joystick, etc.

[:I]I need to get to Maplin or RS electronics and try to find equivalents.
I got round this problem by cutting open a monitor D plug and removing 4 pins along with 15cm of wire.
These I had to Superglue into place on the White Multi conector so as they would not fall out. The position of these pins is as in the listing above.
With the ECU removed it should look like this-
Posted Image


I then joined the wires from the CC loom to the wires from the D plug pins by cutting off the existing 4 conectrs from the CC loom (not the one for the fuse) and soldering the wires together.
When cool I covered the joints with insulating tape and secured in place. If you are able to get new conectors these can be fitted straight onto the CC loom wires.
One other thing I came across when I was doing this job, the wiring diagrams for the 98 to 2000 Passat is the same as the one for the 2001 onwards. I don?t know if the multi plug is the same colour but the wires are the same colour.
Hope this helps.
Good Luck

PS One last thing to remember if your car has ESP or equivelent. When removing the module from behind the steering wheel and before you get to the stalk, it is worth keeping the center plate from turning. There is a thread somewhere with problems with a ESP warning light staying on if this is not located back in it's origional position. It has to be reset if this happens. There are instructions here somewhere but the best advise is prevention not cure
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #18 ·
Tom/Foxy, I've been and got a D plug from Maplins, but need more info, did you remove the multi plug from the loom, or make extra connections? Also when you say the ECU is in the bulk head in front of the steering wheel, is that in the steering cowl, or under the bonnet, under the plastic cover below wipers?
 

·
Registered
Joined
·
51 Posts
Quote: posted by dava on 03/12/2004 21:49:46

Tom/Foxy, I've been and got a D plug from Maplins, but need more info, did you remove the multi plug from the loom, or make extra connections?

The pins from Maplin, I connected to the Cruse Control Loom at the lose conectors end. The small black multi plug is needed for connecting to the stalk. Follow Foxys instructions up to this point. Where the instructins need to be altered is where Foxy refers to "...pushing the lose conectors into a black multi plug..." For the Passat this multi plug is White as seen in the photo. The location for the pins is listed in the instructions above.

The ECU is under the bonnet.

Sorry I have been away from home the past few days and not been able to get back to you sooner.

Thanks Foxy for sorting out the photos for me.

Tom
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top