Volkswagen Mark IV Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
I posted this to the Ross-Tech forums but haven't made much progress. I have converted my US Jetta to 4Motion. With the info of past threads in this and other forums, I am 99% sure I have the correct combination of parts. I have a 2004 TDI, the 3-sensor version of the G251 module, an MK60 ABS module from a 4Motion R32/Bora and the correct ABS sensors. Additionally, my car came with ESP.

However, no matter what we try, the ABS module will only accept front wheel drive coding, e.g. 23049 and 23177. It will not accept any coding that would be appropriate for a 4Motion car. I have been getting help from many people, including the forum user Graeme in Australia, and we're all stumped. I have re-coded the CAN Gateway and cycled the key.

I am hoping maybe someone here will have some ideas.

The only error code during a scan is:

Address 03: ABS Brakes Labels: 1C0-907-37x-ESP-A.lbl
Part No: 1C0 907 379 P
Component: ESP ALLRAD MK60 0101
Coding: 0023049
Shop #: WSC 31414 000 00000
VCID: 373EC8524799FE373E-5184

1 Fault Found:
01044 - Control Module Incorrectly Coded
000 - -
 

·
Registered
V6 4Motion
Joined
·
947 Posts
My coding is;

Address 03: ABS Brakes
Controller: 1C0 907 379 F
Component: ESP ALLRAD MK60 0104
Coding: 0023046

The coding from the Rosstech wiki never quite added up to my factory 0023046 once you add up all the various bitmasks from their guide I ended up with 0023047

0004097 = Drive-By-Wire Engines
+0000518 = FN3 54 15"/16" (PR-1LE/1LJ/1LN/1LQ/1LT/1ZD/1ZE/1ZH)
+0018432 = Gasoline Engine (from 92 kW / 125 HP) & All Diesel Engines

=0023047 (rather than my 0023046)

Not sure what that one bit controls but here are the notes that I made on the binaries in case that helps you track down your issue ( please double-check but I think I'm good with my assumptions)

0101101000001001 R32
0101001000001001 R32 ESP Off
0101101000000110 4mo (Coding: 0023046)
0101101000000111 Ross-tech 4mo
0101001000000110 4mo ESP Off
0100100000000000 Gasoline Engine (from 92 kW / 125 HP) & All Diesel Engines
0001000000000001 DBW
0000001000000110 Brakes 16
0000001000001001 Brakes 17
0000010000000001Cable
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
Thanks for the info.

That seems weird that your factory code would be that high.

If we use the Ross-Tech web site, the All-Wheel-Drive coding doesn't use the numbers 1024/4096 for Cable-Throttle/Drive-By-Wire when adding up the final code. The popup window in VCDS also doesn't show the 1024/4096:


I have a photo of VCDS too.

I can try 0023046 though.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #5 ·
My coding is;

Address 03: ABS Brakes
Controller: 1C0 907 379 F
Component: ESP ALLRAD MK60 0104
Coding: 0023046

The coding from the Rosstech wiki never quite added up to my factory 0023046 once you add up all the various bitmasks from their guide I ended up with 0023047

0004097 = Drive-By-Wire Engines
+0000518 = FN3 54 15"/16" (PR-1LE/1LJ/1LN/1LQ/1LT/1ZD/1ZE/1ZH)
+0018432 = Gasoline Engine (from 92 kW / 125 HP) & All Diesel Engines

=0023047 (rather than my 0023046)

Not sure what that one bit controls but here are the notes that I made on the binaries in case that helps you track down your issue ( please double-check but I think I'm good with my assumptions)

0101101000001001 R32
0101001000001001 R32 ESP Off
0101101000000110 4mo (Coding: 0023046)
0101101000000111 Ross-tech 4mo
0101001000000110 4mo ESP Off
0100100000000000 Gasoline Engine (from 92 kW / 125 HP) & All Diesel Engines
0001000000000001 DBW
0000001000000110 Brakes 16
0000001000001001 Brakes 17
0000010000000001Cable
What specific MK4 do you have?
 

·
Registered
Joined
·
11,308 Posts
I have found that sometimes the cheap copy cables do not work well when coding... but use a OEM ross-tech cable and the coding goes right... this might be the problem here as you don's state if you are using an OEM ross-tech cable or a cheap clone one... I'd say either buy a proper cable, or find someone that has it so he can do the coding for you.
 

·
Registered
V6 4Motion
Joined
·
947 Posts
UK Spec Golf 2.8 V6 4motion BDE engine code, Drive by Wire . I thought I had an issue with my ABS a while back (turned out is was a failed Yaw sensor) and bought another ABS module, same part no that is coded the same, so I'm pretty sure it's standard for this model
 

·
Registered
V6 4Motion
Joined
·
947 Posts
I have found that sometimes the cheap copy cables do not work well when coding... but use a OEM ross-tech cable and the coding goes right... this might be the problem here as you don's state if you are using an OEM ross-tech cable or a cheap clone one... I'd say either buy a proper cable, or find someone that has it so he can do the coding for you.
Good point, I also read that you need a workshop code set in the dongle/VCDS - pretty sure I needed it set when re-coding my dash instrument replacement
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #9 ·
Thanks for the info.

I have a fully licensed unlimited VIN VCDS cable, the current model. I also had read about making sure to use a workshop code, and have been doing so.

I am just guessing at this point, but could the ECU be forcing the ABS module only to accept certain codes? I had an idea to look at the "Engine" coding. When you all look here on your cars, do you see options for "All Wheel Drive" or "4Motion" or "6-speed Manual?" Is it odd my popover doesn't show those options? Or, am I making a connection that isn't a valid connection to make?

Gadget Font Line Communication Device Technology
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #10 ·
I think I might've figured out the issue. In all this time, I'd never cracked open my Bentley manual. In the Scan Tool section for ABS, I just read this:

3. Specific ECM part numbers will only recognize the values listed above as valid.
And, Ross-Tech seems to back up this idea:

Rectangle Font Screenshot Parallel Number


The Bentley manual also verifies codes 23046 and 23174 as being correct (+/- 128 for the rough road suspension option.) I think Ross-Tech's wiki article may have incorrect info (which they also confirm as a possibility in the same forum thread.)
 

·
Registered
Joined
·
11,308 Posts
well i knew you weren't the first with this problem, but i never ran into it myself ... so can't advise further.... will keep my eyes on it though as this is an interesting problem.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #12 ·
Malone responded to my 4Motion question. They're asking if I know what the coding should be. How I might determine this? The popover I see in VCDS doesn't show the numbers for "All Wheel Drive" or "6-Speed Manual Transmission." My Bentley manual doesn't seem to have the programming info for TDI's other than the ALH, even though my copy is from 2005. Is there any other resource I can use? I found one older Ross-Tech thread for a guy in Canada that imported a 4Motion ATD TDI, and his coding was 0000003, but Googling that part number (038906019DD) seems to indicate that it is an EDC15 instead of an EDC16 like mine.

There were 4Motion TDI's with an EDC16 ECU, right?
 

·
Registered
Joined
·
11,308 Posts
if there where you are asking the wrong people... head over to a German website as we never got a 4 motion TDI in the mK4 from the factory... Germany has them, as do all the Nordic countries
 
1 - 13 of 13 Posts
Top