Volkswagen Mark IV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
Hi friends. To make the story short, I send you a small summary here. Almost 2 years ago I upgrade my whole brake system of my car (2002 VW Golf GTI 1.8T AGU with MK60 brake system) using ECS Stage 1 (13.1in Fr rotors) and ECS Stage 1R (12in Rr rotors) big brake kits, with OEM calipers, Tyrolsport brass bushings for front calipers, Ferodo DS2500 pads front, Hawk HPS rear pads, Russell SS brake lines F&R and ATE Typ200 brake fluid. As you can see almost everything was new, whole stuff was installed according to the service manual, brakes and ABS pump was purged several times following the service manual procedure. Inclusive the dealer do it two times too.

Ok but the problem is that from the first day I upgrade the brakes, I notice some inconsistent brake feel, sometimes is up, sometimes it get more travel. Also I can notice some pedal sink when you push hard on it with car stoped but engine running. My first impression was to purge whole brake system including ABS pump, but until know it was done more than 6 times including dealer. After all these test I start thinking that the master cylinder could be causing all this issues, and it was changed 6 months ago. But the weird pedal feel remains after that too. I have contacted many people and I receive some advice about some cars (MK4 Golfs with MK20 brake system) showing the same issues but without an specific solution. Also I read some problems about ATE Super Blue brake fluid (the same Typ200 fluid but with the blue dye) with some ABS pumps and Clutch cylinder, then the problem was solved changing the brake fluid.

Then friends I will like to know if everyone had this issues and if any of you found how to solve the problem. Comments and ideas are welcome.
 
1 - 2 of 2 Posts
Top