Volkswagen Mark IV Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hello I have a problem with my golf tdi 2003 when I startup car turn igntion on battery light stays on and tells me to service now although I just put in a brand new BOSCH battery??


Also When I start up I also get the message that my coolant needs checking and that I need to stop , but ive checked and it has sufficient amount of water inside?

Anyone know why it does this? Any solutions will be much appreciated
 

·
Kitty-wake!
Joined
·
4,162 Posts
Does the battery light ONLY come on when the ignition is on...not the engine? If thats the case that is normal...if its on when the engine is running then you have a problem.

And there are 2 metal sticks in the coolant tank, is coolant covering them? If there is, can always try buying a new tank as they can sometimes brake like mine did! the tanks are cheap to buy!
 

·
Super Moderator
Joined
·
50,219 Posts
Calling it a battery warning light is a misnomer as it can't tell you anything about the battery,it will only tell you if the alternator isn't charging it properly.
Some tests you can do below,but it's most likely your alternator that's faulty......

HOW TO TEST
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Thanks for quick response and its only on when ignition is on and not when engine is on so I guess its fine now you said, and the computer still tells me to service now though? How would I fix that ?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
Also I think it may be alternator because this morning took a little longer then normal starting up half a second longer or so but noticeable difference, this is with the new battery bought at the start of this week so it sounds like it is probably alternator I have a Halfords down the road for me ill let them check it out because I dont have the equipment
 

·
Registered
Joined
·
1,296 Posts
dont sound like alternator at all to me,,,

factor in the cold weather, its not gonna fire on half a turn

when was the last time it had a service?

if recent you can reset it yourself

switch off the ignition,
press and hold the mileage trip reset button,
switch on ignition,
release trip button,
service indicator will appear,
turn the clock adjust button clockwise and hold in for about 5 seconds,and the service now reminder should go.
release the button and turn off the ignition.
when you turn ignition back on service now reminder should be gone.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
Thanks for the tip I will try and reset the service lights this evening or tomorrow and let you know how it goes
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top