Volkswagen Mark IV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,401 Posts
Discussion Starter · #1 ·
Bit of an intermittent problem that I've got with the VR.

When I'm at high revs, I sometimes get alternator workshop appear with the battery light flashing - is this likely to be the voltage regulator? Or am I looking at a complete alternator? Any chance it's just a slipping belt?

There's also a slight whine when getting through the revs, which I have a feeling is linked and is the alternator. Like on the TDIs, is the alternator pulley a clutched pulley?

Unsure if related (probably is), but when cold, there's a small squeak from the accessories, haven't yet looked into whether it's belt, tensioner or an accessory pulley.

And lastly, doesn't look like there's much room around it, so is pulling the front end off the easiest way to get to the alternator, or is there another way to fish it out?

Voltage at idle seems normal, around 13.7V.

TIA, as always.
 

·
Registered
Joined
·
11,256 Posts
get your battery tested, 9 out of 10 times it's not the alternator but the battery that causes the light on at high revs.... and if it is the alternator it might just be the regulator that needs replacing, but the age your car is at IMO i would just replace it with a new alternator. It also s the perfect time to upgrade it to a higher amp version

and the reason why i would replace it for a new unit is because if youve never chanced it in your ownership chances are it is the original unit and the bearings will have play by now... so best solution replace the unit... if you don't run power hungry accessories than you can go for a refurbished one that is like for like... but I would skip that and go for a higer output one regardless of the battery size and the accessories i'm running ( TBT i always get the highest amp one since i always run subwoofers and amps)
 
1 - 2 of 2 Posts
Top